Starting with version 7.0 of the app, only Android 4.4 (KitKat) and later versions are supported. If your device is still on an older Android version, please see the older app versions.

 

If you run into any problem while using the application, please let us know through the contact form. We’d love to hear from you, even if you don’t have any problem to report. Thank you!