0
0

This seems to be a great app. I am trying to record from a USB camera with Android 8.1 on an ODroid XU4. Most other apps fail to even display the video in the proper aspect resolution, but DailyRoads seems fine with displaying and recording.

Unfortunately, it freezes and then crashes during or after the second recording.

I have uploaded the App’s own log file as well as the full ADB logcat here:

http://oliford.co.uk/files/noIndex/dailyroads-crash/

The final kill by Android is in daily-adb-logcat-04-start-ok-stop-crashes.log:

“12-22 13:51:45.013 3296 3314 I ActivityManager: Killing 5787:com.dailyroads.v.pro/u0a86 (adj 0): user request after error”

Once the crash has occured, restarting the app displays video, but refuses to start recording again (“Sorry, video recording could not be initialized”). It requires a full reboot to work again, once.

I would appreciate if you could take a look at this.

Many thanks,

Oliver

  • You must to post comments
0 votes
10k views
Друзья! А разве купленное приложение я не могу установить на два своих устройства? Планшет и смар...
  • Anonymous asked 2 years ago
  • last active 2 years ago
1 vote
5k views
Hi, I’m new to the app, and saw in the settings I can choose to save 1-3 videos. How can I ...
  • Darius asked 2 years ago
  • last active 9 months ago
0 votes
4k views
I have the default 180 seconds specified for video length in the settings, but sometimes shorter ...
  • John asked 2 years ago
  • last active 2 years ago
Showing 41 - 43 of 43 results
0
0

Don’t worry about this. I have found a different app that works and also supports two cameras simultaneously. It is more targeted towards developers and gives much better debugging information.

Thank you for your efforts anyway,

Oliver

  • You must to post comments
0
0

I am not sure that the problem has anything to do with the camera because when DailyRoads freezes, the live video displayed continues. Also, when the app is run again after the crash, it is able to display the live camera image again with no problem. The camera driver (and yes, also its firmware) appears to be working. The problem seems to be to do with the recording (or maybe transcoding? if it is doing it).

I have tried it with a different model of USB camera (though, it still works through uvcvideo), and it does exactly the same.

I was wondering if this could instead be something to do with the audio? I am not sure the audio on this system is setup correctly, and there is no microphone. Is it possible to entirely disable the audio recording?

Many thanks,

Oliver

  • You must to post comments
0
0

Thanks for making the log files available. Unfortunately, there is no clear problem there which we could fix in the app. It looks like the camera firmware is just not stable enough. There are all kinds of Android devices where the camera firmware only works well for a very limited set of use cases.

During the years we’ve tried various potential fixes in the app for head units (car stereos), but the only real fix came with a camera firmware update. This seems to be the case here, too.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.